Server 3.1.0-rc2 (Buster fix)

  • FIX: Resolve PHP problems preventing installation

This release focuses solely on a Debian 10 (Buster) installation problem discovered after 3.1.0-rc2.  This fix is for Debian 10 Buster only.

After this you can run this command to update your repository to the unstable repository and install version 3.1.0-rc1

sudo bash -c "$(curl -s https://dl.bluecherrydvr.com/scripts/install-unstable)

If you DO NOT want to upgrade and want to keep the currently installed Bluecherry version please run:

sudo apt-mark hold bluecherry

Server 3.1.0-rc2 released

  • FIX: Resolve large memory leak, causing OOM failure sometimes as soon as 1 hour (0132827)
  • FIX: Resolve buffer append crash (6bc8cee)

This release focuses solely on all crashes that was reported to Bluecherry, including a nasty memory leak and a crash that occurred every hour.  

Note:  Currently the SSL / CNAME section is disabled and will be added soon.

Please post any questions / comments on our community forums or on our Slack channel.

If you are running v2 and want to try v3.1.0-rc1 it is recommended that you first backup your database:

mysqldump -u bluecherry -p bluecherry >> bluecherry-v2.dump

After this you can run this command to update your repository to the unstable repository and install version 3.1.0-rc1

sudo bash -c "$(curl -s https://dl.bluecherrydvr.com/scripts/install-unstable)

If you DO NOT want to upgrade and want to keep the currently installed Bluecherry version please run:

sudo apt-mark hold bluecherry

Server 3.1.0-rc1 released

  • FEATURE: Migrate completely to nginx instead of Apache (#436)
  • FEATURE: Support HLS web streaming for live view (#437)
  • FEATURE: Allow trial licenses
  • FEATURE: Start initial work to support Lets Encrypt SSL (will be fully added in -RC2) -- Requires paid license.

Currently packages are available for Ubuntu 18.04, Ubuntu 20.04 and Debian Buster.

Update 6/8/2021: Packages for Ubuntu 20.10 (groovy), Ubuntu 21.04 (hirsute) and Debian Bullseye are now available.

 Ubuntu 20.10 and Debian Bullseye are expected in the near future

Note:  Currently the SSL / CNAME section is disabled and will be added soon.

Please post any questions / comments on our community forums or on our Slack channel.

If you are running v2 and want to try v3.1.0-rc1 it is recommended that you first backup your database:

mysqldump -u bluecherry -p bluecherry >> bluecherry-v2.dump

After this you can run this command to update your repository to the unstable repository and install version 3.1.0-rc1

sudo bash -c "$(curl -s https://dl.bluecherrydvr.com/scripts/install-unstable)" 

Server 3.0.6 released

  • FIX: Lack of string etiquette in the trigger server, resolve buffer overrun (#434)
  • FIX: Nasty storage deletion routine bug where old videos may not be deleted, resulting in 100% disk usage and failure to components (#433)
  • FIX: Web: Layout problem when cameras are disabled (#227)
  • FEATURE: Auto-expand IP Cameras in Devices page (#430)

Attention!

Due to a issue with Ubuntu 18.04 installing mysql-server-5.7 at the same time as the bluecherry 3.0.6 update the first upgrade will fail.

The preferred method is to run these commands:

sudo apt-get update ; sudo apt-get install mysql-server-5.7 ; sudo apt-get install bluecherry

Server 3.0.5

  • FIX: Web playback - AJAX error caused by the wrong time format (#388)
  • FIX: Fixed segment violation bug in recording schedule (#425)
  • FIX: Change VAAPI to ‘None’ by default (#421)
  • FIX: Web backup / restore - Fixed problem where backup and restore would always fail (#414 / #409)
  • FIX: Fix mailer.php (attachments were broken) (#405)
  • FIX: TLS / SASL improvements (#366)
  • FEATURE: Support systemd (allowing for newer Ubuntu distributions) (#406)
  • FEATURE: Adds temporal-based motion detection algorithm - Added by Kyle Mallory kylemallory@yahoo.com
  • FEATURE: Minor improvements to Experimental motion detection algorithm, specifically support for “max motion area”. - Added by Kyle Mallory kylemallory@yahoo.com